Задать вопрос
2 августа, 06:59

Даны натуральные числа n и m. Составьте программу, которая вычисляет сумму последних m цифр числа n.

+4
Ответы (1)
  1. 2 августа, 08:59
    0
    Pascal

    var m, n, i, z, p:integer;

    begin

    readln (m) ;

    readln (n) ;

    for i:=1 to m do

    begin

    p=n mod 10;

    z=z+p;

    end;

    writeln (z) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны натуральные числа n и m. Составьте программу, которая вычисляет сумму последних m цифр числа n. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
2. Составить программу, которая вычисляет количество чисел кратных 3, 4 и 5 одновременно в диапазоне от 1 до 1000. 3. Составить программу, которая вычисляет факториал числа 7!
Ответы (1)
Составить программу, которая вычисляет среднеарифметическое чисел, кратных 3 в диапазоне от 1 до 200. Составить программу, которая вычисляет факториал числа 7!
Ответы (1)
Напишите программу, которая вычисляет НОД двух чисел. Используйте функцию. Напишите программу, которая вычисляет НОК двух чисел. Используйте функцию.
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)