Задать вопрос
31 января, 21:33

Написать программу. Программа должна осуществлять ввод и печать исходного одномерного массива; выполнять в соответствии с условиями действия и печатать результаты. Вычислить сумму ненулевых чисел, стоящих на четных местах, и подсчитать количество чисел, принадлежащих промежутку [M, K].

+1
Ответы (1)
  1. 1 февраля, 01:04
    0
    var a:array[1 ... 10,1 ... 10]of integer;

    i, j, m, k, s:integer;

    begin

    for i:=1 to 10 do for j:=1 to 10 do readln (a[i, j]) ;

    for i:=1 to 10 do begin for j:=1 to 10 do write (a[i, j],' ') ; if j=10 then writeln; end;

    for i:=1 to 10 do

    for j:=1 to 10 do

    if (a[i, j]0) and (i mod 2=0) then s:=s+a[i, j];

    writeln (s) ;

    readln (m, k) ;

    s:=0;

    for i:=1 to 10 do

    for j:=1 to 10 do

    if (a[i, j]>=m) and (a[i, j]<=k) then s:=s+1;

    writeln (s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу. Программа должна осуществлять ввод и печать исходного одномерного массива; выполнять в соответствии с условиями ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Сделать программу в Pascal. 1. Организуйте ввод и вывод одномерного массива в строку, в столбец. 2. Найдите произведение ненулевых элементов одномерного массива. 3.
Ответы (1)
Помогите решить задачи в паскале. 1) найти сумму положительных элементов массива. 2) найти сумму четных элементов массива. 3) найти сумму всех четных элементов массива, стоящих на четных местах.
Ответы (1)
Найдите среднее арифметическое чисел, принадлежащих промежутку [A, B), и количество положительных чисел, стоящих на местах, кратных 4 паскаль решить задачу в паскаль с помощью одномерного массива
Ответы (1)
Pascal ABC Вычислить сумму квадратов отрицательных чисел, стоящих на местах, кратных 3; подсчитать количество чисел, не принадлежащих промежутку [А, В).
Ответы (1)
Написать программу:"Дано четырехзначное число. Что больше: сумма цифр, стоящих на четных местах, или сумма цифр, стоящих на не четных местах?"
Ответы (1)