Задать вопрос
14 мая, 20:37

Заполните массив 11-ю случайными числами промежутка [-20; 10]. Выведите его в строке. Все элементы с нечетными значениями уменьшите в 3 раза, а остальные - увеличьте на 5. Выведите новый массив

+4
Ответы (1)
  1. 15 мая, 00:07
    0
    var a:array[1 ... 11]of integer;

    i:integer;

    begin

    randomize;

    for i:=1 to 11 do a[i]:=random (31) - 20;

    for i:=1 to 11 do write (a[i],' ') ;

    writeln;

    for i:=1 to 11 do if a[i] mod 20 then a[i]:=a[i] div 3 else a[i]:=a[i]*5;

    for i:=1 to 11 do write (a[i],' ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Заполните массив 11-ю случайными числами промежутка [-20; 10]. Выведите его в строке. Все элементы с нечетными значениями уменьшите в 3 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Составте программуб которая заполняет массив а[1 ... 10] случайными целыми числами в диапозоне от 1 до 10, затем преобразовывает его, увеличивая все элементы с четными значениями на 1.
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
1. Заполнить массив а [1 ... 14] случайными целыми числами в диапазоне от 1 до 18 и вывести на экран элементы массива с нечетными значениями, меньшими 10. 2. Заполнить массив а [1 ...
Ответы (1)
Cоставьте программу, которая заполняет массив а [1 ... 10] случайными целыми числами в диапазоне от 1 до 10, затем преобразовывает его, увеличивая все элементы с нечётными значениями в три раза, а элементы с чётными значениями заменяя на 0.
Ответы (1)