Задать вопрос
7 июня, 04:29

Помогите! Написать программу, которая определяет кратна ли числу А сумма цифр двухзначного числа

+3
Ответы (2)
  1. 7 июня, 05:59
    0
    Блин что за муть как сложно, думаю как решить)
  2. 7 июня, 06:26
    0
    var a, a1, a2, a3:integer;

    begin

    read (a) ; - читаем данное число

    a1:=a mod 10;

    a2:=a div 10;

    a3:=a1+a2;

    if a3 mod = 0 then write ('да')

    else (write ('нет') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите! Написать программу, которая определяет кратна ли числу А сумма цифр двухзначного числа ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Домашнее задание: 1. Запишите на языке Паскаль программу, которая для произвольного двузначного числа определяет сумму и произведение его цифр. 2.
Ответы (1)
Дано двузначное числи. Определит. А) кратна ли трем сумма его цифр Б) кратна ли сумма его цифр числу a.
Ответы (1)
1. Составьте программу, которая определяет, является ли сумма цифр введенного целого трехзначного числа четным числом. 2. Составьте программу, которая определяет, является ли последняя цифра введенного целого числа нечетным числом. 8 класс.
Ответы (1)
2. Разработать программу, которая запрашивает ввод целого числа в переменную Z, определяет и выводит на экран сообщение, какое это число - положительное, отрицательное или равное 0.
Ответы (1)
1) Напишите программу, которая определяет, верно ли, что введенное число состоит из одинаковых цифр (например, 222) 2) Напишите программу, которая определяет, верно ли, что введеное число содержит две одинаковые цифры, стоящие рядом (например, 221)
Ответы (1)