Задать вопрос
2 мая, 09:40

составить программу, которая заполняет массив а [1 ... 10] случайными целыми числами в диапазоне от 0 до 10 и находит максимальный элемент массива среди элементов с чётными индексами

+2
Ответы (1)
  1. 2 мая, 10:32
    0
    var

    a: array [1 ... 10] of integer;

    i, max: integer;

    begin

    max: = 0;

    write ('Исходный массив: ') ;

    for i: = 1 to 10 do

    begin

    a[i]: = random (10) ;

    write (a[i], ' ') ;

    if (i mod 2 = 0) and (a[i] > max) then

    max: = a[i];

    end;

    writeln;

    writeln ('Максимальный элемент массива среди элементов с четными индексами: ', max) ;

    end.

    Если что не понятно - спрашивай.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «составить программу, которая заполняет массив а [1 ... 10] случайными целыми числами в диапазоне от 0 до 10 и находит максимальный элемент ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
составьте программу, которая заполняет массив a[1 ... 10]случайными целыми числами в диапазоне от 0 до 10 и находит максимальный элемент массива среди элементов с чётными индексами
Ответы (1)
Составьте программу заполняет массив [1 ... 10] случайными целыми числами в диапазоне от 0 до10 и находит максимальный элемент массива среди элементов с четными индексами
Ответы (1)
1. Cоставьте программу, которая заполняет массив a [1 ... 10] случайными целыми числами в диапазоне от 1 до 10, затем преобразовывает его, увеличивая все элементы с чётными значениями на 1.
Ответы (1)