Задать вопрос
15 октября, 05:58

составьте программу, которая заполняет массив a[1 ... 10]случайными целыми числами в диапазоне от 0 до 10 и находит максимальный элемент массива среди элементов с чётными индексами

+3
Ответы (1)
  1. 15 октября, 08:27
    0
    var

    a: array [1 ... 10] of integer; / / Массив из 10 целых элементов

    max, i: integer; / / max - максимальный элемент

    begin

    max: = 0; {Присваиваем max минимальное значение, которое он может принять}

    write ('Исходный массив: ') ; {Заполняем исходный массив, печатаем его и находим максимальный элемент}

    for i: = 1 to 10 do

    begin

    a[i]: = random (10) ;

    write (a[i], ' ') ;

    if (i mod 2 = 0) and (a[i] > max) then

    max: = a[i];

    end;

    writeln ('Максимальный элемент массива среди элементов с четными индексами: ', max) ; / / Печатаем исходный элемент

    end.

    Если все правильно, отметь решение как лучшее)
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «составьте программу, которая заполняет массив a[1 ... 10]случайными целыми числами в диапазоне от 0 до 10 и находит максимальный элемент ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
составить программу, которая заполняет массив а [1 ... 10] случайными целыми числами в диапазоне от 0 до 10 и находит максимальный элемент массива среди элементов с чётными индексами
Ответы (1)
Составьте программу заполняет массив [1 ... 10] случайными целыми числами в диапазоне от 0 до10 и находит максимальный элемент массива среди элементов с четными индексами
Ответы (1)
1. Cоставьте программу, которая заполняет массив a [1 ... 10] случайными целыми числами в диапазоне от 1 до 10, затем преобразовывает его, увеличивая все элементы с чётными значениями на 1.
Ответы (1)