Задать вопрос
25 января, 20:33

написать программу, которая вводит массив из N целых чисел и выводит на экран элементы, кратные числу K.

+3
Ответы (1)
  1. 25 января, 23:33
    0
    const

    N = 10;

    var

    a: array [1 ... N] of integer;

    i, K: integer;

    begin

    writeln ('Введите число K') ;

    readln (K) ;

    for i: = 1 to N do

    begin

    writeln ('Введите целое число') ;

    readln (a[i]) ;

    end;

    writeln ('Числа, кратные числу ', K, ':') ;

    for i: = 1 to N do

    if a[i] mod K = 0 then writeln (a[i]) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «написать программу, которая вводит массив из N целых чисел и выводит на экран элементы, кратные числу K. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Разработать схему алгоритма, который вводит массив из Nцелых чисел и выводит на экран этот же массив в прямом и обратном порядке. Протестировать алгоритм на произвольных массивах, состоящих из 1 числа, из 5 чисел, из 10 чисел. 2.
Ответы (2)
доброго времени суток.) кто-нибудь может помочь? ибо я совсем не вывожу информатику. 1. Написать программу, которая вводит массив из N целых чисел и выводит на экран элементы с чётными номерами.
Ответы (1)
Напишите программу, которая вводит массив из N целых чисел и выводит на экран элементы, кратные числу K. Протестировать программу на следующих исходных данных: а) k=3 Массив: 2 6 - 9 4 5 12 - 15 б) k=4 Массив: 9 0 8 124 - 16 11 19
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
Помогите написать программу в Python. 1) Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4 ...). 2) Дан массив, состоящий из целых чисел.
Ответы (1)