Задать вопрос
7 сентября, 04:25

Среди 20 вводимых чисел выберите все кратные 2 или кратные 5 и подсчитайте их сумму. (В Паскале)

+3
Ответы (1)
  1. 7 сентября, 07:17
    0
    var a:array[1 ... 10] of integer;

    s, s1:longint;

    i, n:integer;

    begin

    n:=20;

    s:=0; s1:=0;

    for i:=1 to n do

    begin

    writeln ('Vvedite element ', i) ;

    read (a[i]) ;

    end;

    for i:=1 to n do

    begin

    write (a[i]:4) ;

    end;

    writeln;

    for i:=1 to n do

    begin

    begin

    if (a[i] mod 2=0) then s:=s+a[i];

    end;

    begin

    if (a[i] mod 5=0) then s1:=s1+a[i];

    end;

    end;

    writeln ('Summa kratnix 2 = ', s) ;

    writeln ('Summa kratnix 5 = ', s1) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Среди 20 вводимых чисел выберите все кратные 2 или кратные 5 и подсчитайте их сумму. (В Паскале) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Написать программу, вычисляющую сумму отрицательных чисел, кратных 5, среди пяти, вводимых с клавиатуры. 2. Написать программу, вычисляющую произведение чисел, оканчивающихся цифрами 2 и 4, среди пяти, вводимых с клавиатуры. 3.
Ответы (1)
помогите решить три номера! 1. Вычислите сумму данных 100 натуральных чисел. Вводятся 100 чисел, сумму которых необходимо посчитать. 2. Вводится число N, а затем N чисел. Подсчитайте, сколько среди данных N чисел нулей. 3.
Ответы (1)
помогите решить. Всё в с++, для code blocks. 1. Вычислите сумму данных 100 натуральных чисел. Вводятся 100 чисел, сумму которых необходимо посчитать. 2. Вводится число N, а затем N чисел. Подсчитайте, сколько среди данных N чисел нулей. 3.
Ответы (1)
Вычислите сумму всех нечетных чисел из десяти вводимых. В паскале.
Ответы (2)
Нужно составить программу, вычисляющую сумму только положительных чисел из трех вводимых с клавиатуры. в Турбо Паскале
Ответы (2)