Задать вопрос
1 января, 03:58

Известны год и номер месяца рождения человека, а также год и номер месяца сегодняшнего дня (январь - 1 и т. д.). Определить возраст человека (число полных лет). В случае совпадения указанных месяцев считать, что прошел весь год. Паскаль.

+2
Ответы (1)
  1. 1 января, 06:21
    0
    Учитесь, любители)

    program prosto tak;

    uses crt;

    var

    x, y, a, b, i, k:integer;

    begin

    readln (x, y) ;

    readln (a, b) ;

    k:=0;

    k:=a-x;

    if (b>y) or (b=y) then k:=k+1;

    writeln (k) ;

    readln;

    end.

    должно заработать
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Известны год и номер месяца рождения человека, а также год и номер месяца сегодняшнего дня (январь - 1 и т. д.). Определить возраст ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Ввести последовательно возраст Антона, Бориса и Виктора. Определить, кто из них старше. Пример: Возраст Антона: 15 Возраст Бориса: 17 Возраст Виктора: 16 Ответ: Борис старше всех. На C + + или Паскаль.
Ответы (1)
Задание 1. Ввести номер месяца и вывести количество дней в нем, а также число ошибок при вводе. Пример: Введите номер месяца: -2 Введите номер месяца: 11 В этом месяце 30 дней. Вы вводили неверно 1 раз. Задание 2.
Ответы (1)
Помогите составить программу) Введите исходные данные: Возраст Коли: 12 Возраст Миши: 17 Средний возраст: 14.5 лет Возраст Колт отличается от среднего возраста на: - 2.5 лет Возраст Миши отличается от среднего возраста на: 2.5 лет
Ответы (1)
Возраст Тани - X лет, а возраст Мити - Y лет. Найти их средний возраст, а также определить, насколько отличается возраст каждого ребенка от среднего значения.
Ответы (2)