Задать вопрос
29 сентября, 21:19

Найти число пар "соседних" элементов массива, являющихся четными и кратные 3

+2
Ответы (1)
  1. 30 сентября, 00:46
    0
    В цикле, кажется, так:

    for I:=1 to N do

    If (Mas[I] mod 2 = 0) and (Mas[I] mod 3 = 0) and (Mas[I+1] mod 2 = 0) and (Mas[I+1] mod 3 = 0)

    then Sum:=Sum+1;

    Перед этим, конечно, нужно заполнить массив. N - число элементов и обнулить сумму. Можно заполнить в том же цикле:

    Sum:=0;

    writeln ('Число элементов:') ;

    readln (n) ;

    writeln ('Числа:')

    for I:=1 to N do begin

    readln (Mas[I]) ;

    If (Mas[I] mod 2 = 0) and (Mas[I] mod 3 = 0) and (Mas[I+1] mod 2 = 0) and (Mas[I+1] mod 3 = 0)

    then Sum:=Sum+1;

    end;

    writeln ('Sum=', Sum) ;
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти число пар "соседних" элементов массива, являющихся четными и кратные 3 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Дан массив a состоящий из n целых чисел. Требуется найти количество пар соседних элементов массива, являющихся четными числами.
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
Массив заполнен случайным образом 20 числами в интервале от 0 до 100. 1) найти максимальный и минимальный элемент массива, а так же их сумму 2) найти среднее арифметическое элементов массива 3) из элементов массива сформировать два массива с четными
Ответы (1)
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)