Задать вопрос
25 сентября, 01:50

Нужна помощь: Составить программу по которой компьютер угадает число введеное с клавиатуры (с помощью repeat), с пояснениями (игра похожа на игру угадай число, но угадывает компьютер, а мы задумываем)

+5
Ответы (1)
  1. 25 сентября, 05:03
    0
    var x, y, a:integer;

    c:boolean;

    begin

    readln (x) ; {считываем}

    a:=1;

    repeat

    writeln (a,' попытка выбор компьютера пал на - ') ;

    y:=random (x) + 1; {задаем промежуток рандомом}

    write (y) ;

    if x=y {сравниваем} then c:=true; {выходим из цикла в случае успеха}

    until c; {если с=true тогда выход из цикла, иначе крутимся дальше}

    writeln ('Компьютер сделал ', a,' попыток.') ;

    end.

    Более доработанная и понятная, если возникают какие-то вопросы - пиши в личку.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Нужна помощь: Составить программу по которой компьютер угадает число введеное с клавиатуры (с помощью repeat), с пояснениями (игра похожа ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Какая формула соответствует поиску документа с любым из трех слов? Игра| Инженер | Задача Игра Инженер Задача "Игра * Инженер Задача" "Игра Инженер Задача" Игра + Инженер + Задача Игра - Инженер + Задача
Ответы (1)
Какая формула соответствует поиску документа, который обязательно содержит все три слова? Игра| Инженер | Задача Игра Инженер Задача "Игра * Инженер Задача" "Игра Инженер Задача" Игра + Инженер + Задача Игра - Инженер + Задача
Ответы (1)
Какая формула соответствует поиску документа, содержащего цитату, включая пропущенное слово? Игра| Инженер | Задача Игра Инженер Задача "Игра * Инженер Задача" "Игра Инженер Задача" Игра + Инженер + Задача Игра - Инженер + Задача
Ответы (1)
Составте программу, определяющую, является ли введеное число с клавиатуры целое число четным
Ответы (1)
1) Напишите программу, которая определяет, верно ли, что введенное число состоит из одинаковых цифр (например, 222) 2) Напишите программу, которая определяет, верно ли, что введеное число содержит две одинаковые цифры, стоящие рядом (например, 221)
Ответы (1)