Задать вопрос
5 апреля, 20:36

Каждый из 12 элементов массива Р равен квадрату его индекса. Найти сумму этих квадраторв. (Составить алгоритм решения и программу)

+5
Ответы (1)
  1. 5 апреля, 23:05
    0
    Ну алгоритм: просто суммируешь поочерёдно. (можно кубиками нарисовать, но это мне делать не удобно, тем более не сложно)

    Вот прога на паскале:

    program sym

    var p:array[1 ... 12] of integer;

    s, i:integer;

    Begin

    s:=0;

    For i:=1 to 12 do

    p[i]:=i*i; / / если нет уже готового массива

    For i:=1 to 12 do

    s:=s+p[i];

    write (s)

    end.

    Ну тут кстати массив излишен, если надо просто найти сумму:

    program sym1

    var s, i:integer;

    Begin

    s:=0;

    For i:=1 to 12 do

    s:=s+i*i;

    write (s)

    end.

    Я у себя не проверял, но должно работать)
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Каждый из 12 элементов массива Р равен квадрату его индекса. Найти сумму этих квадраторв. (Составить алгоритм решения и программу) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1 Задание: сформируйте и выведите на экран массив из девяти элементов, каждые три последовательных элемента которого составлены по следующему правилу: 1-й равен значению текущего индекса, увеличенному на 3; 2-й равен квадрату предыдущего индекса;
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)
Сформируйте массив из 10 элементов, каждый элемент которого равен сумме значений его индекса и квадрата индекса. Найдите произведение элементов массива, стоящих на четных местах. Вывести на экран эти элементы и их произведение.
Ответы (2)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)