Задать вопрос
4 октября, 05:15

составьте программу, которая заполняет массив a[1 ... 10]случайными целыми числами в диапазоне от 1 до 10 и выводит на экран последний элемент с нечётным значением и его индекс

+3
Ответы (1)
  1. 4 октября, 08:17
    0
    var

    a: array[1 ... 10] of integer; / / Массив а

    i, index: integer; / / index - индекс последнего элемента с нечетным значением

    begin

    write ('Исходный массив: ') ;

    for i: = 1 to 10 do {Заполняем массив элементами в диапазоне [1 ... 10], печатаем его и определяем индекс последнего элемента с нечетным значением}

    begin

    a[i]: = random (10) + 1;

    write (a[i], ' ') ;

    if a[i] mod 2 = 1 then index: = i;

    end;

    writeln;

    writeln ('Последний элемент с нечетным значением: a[', index, '] = ', a[index]) ;

    end.

    Отметь решение как лучшее)
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «составьте программу, которая заполняет массив a[1 ... 10]случайными целыми числами в диапазоне от 1 до 10 и выводит на экран последний ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
А) Составьте программу, которая заполняет массив В[1 ... 11] случайными целыми числами в диапазоне от - 5 до 5 и преобразовывает его, заменяя элементы кратные 5 на 5, а остальные увеличивая в 5 раз.
Ответы (1)
1. Cоставьте программу, которая заполняет массив a [1 ... 10] случайными целыми числами в диапазоне от 1 до 10, затем преобразовывает его, увеличивая все элементы с чётными значениями на 1.
Ответы (1)
A) Составьте программу, которая заполняет масcив a[10 ... 20] случайными целыми числами в диапазоне от 10 до 20, затем меняет местами первый и последний элементы. Выведите на экран исходный и полученный массивы.
Ответы (1)