Задать вопрос
25 января, 19:35

Задание1: В массиве из 100 случайных целых чисел найти максимальный элемент и количество вхождений этого элемента в массив. Задание2: Реализовать простые операции с матрицами: транспонирование, умножение на число, сложение и перемножение двух матриц. Значения матриц задавать случайным образом, выбор операции предоставлять пользователю.

+5
Ответы (1)
  1. 25 января, 21:20
    0
    1 Задание.

    var

    a:array[1 ... 100] of integer;

    i, max, kol:integer;

    begin

    randomize;

    max:=0;

    for i:=1 to 100 do

    a[i]:=random (101) ;

    for i:=1 to 100 do

    if a[i]>max then max:=a[i];

    for i:=1 to 100 do

    if a[i]:=max then kol:=kol+1;

    write (max, kol) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задание1: В массиве из 100 случайных целых чисел найти максимальный элемент и количество вхождений этого элемента в массив. Задание2: ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
9.65. Дано предложение. Определить: а) число вхождений в него буквосочетания ро; б) число вхождений в него некоторого буквосочетания из двух букв; в) число вхождений в него некоторого буквосочетания.
Ответы (1)
1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный элемент массива. 2.
Ответы (2)
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)
Вычислить сумму и разность двух одномерных массивов содержащих 20 элементов. В массиве суммы найти максимальный элемент и его индекс. В массиве разности найти минимальный элемент и его индекс. Исходные массивы ввести при помощи случайных чисел.
Ответы (1)