Задать вопрос
26 марта, 23:39

В классе 20 учеников писали диктант по русскому. Написать программу подсчета кол-ва 2 3 4 5 получивших за диктант (писать через массива)

+3
Ответы (1)
  1. 27 марта, 01:01
    0
    var

    a: array [1 ... 20] of 2 ... 5; / / Массив оценок учеников

    i: integer;

    n: array [2 ... 5] of 2 ... 5; / / Массив счетчиков оценок

    begin

    for i: = 2 to 5 do / / Обнуляем счетчики оценок

    n[i]: = 0;

    for i: = 1 to 20 do / / Вводим оценки учеников и считаем их

    begin

    writeln ('Введите оценку ', i, ' ученика') ;

    readln (a[i]) ;

    if a[i] = 2 then n[2]: = n[2] + 1;

    if a[i] = 3 then n[3]: = n[3] + 1;

    if a[i] = 4 then n[4]: = n[4] + 1;

    if a[i] = 5 then n[5]: = n[5] + 1;

    end;

    for i: = 2 to 5 do

    writeln ('Количество получивших ', i, ' за диктант равно: ', n[i]) ; {Выводим значения счетчиков}

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В классе 20 учеников писали диктант по русскому. Написать программу подсчета кол-ва 2 3 4 5 получивших за диктант (писать через массива) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Помогите с информатикой 1. Что такое массив? 2. Что такое элемент массива? 3. Что такое индекс массива? 4. Что такое размерность массива? 5. Зачем нужны массивы? 6. Как можно обратиться к ячейке массива? 7. Какого типа могут быль элементы массива? 8.
Ответы (1)
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)