Задать вопрос
5 мая, 00:38

Дан двумерный массив сосстоящий из 4 строк и 5 стобцов и заполненный случайным образом целыми числами от 1 до 100 ... Найти разность максимального и минимального элемента массива.

+5
Ответы (1)
  1. 5 мая, 00:50
    0
    var

    a: array [1 ... 5, 1 ... 4] of integer;

    min, max: integer;

    i, j: integer;

    begin

    min: = 100;

    max: = 1;

    write ('Исходный массив: ') ;

    for i: = 1 to 5 do

    for j: = 1 to 4 do

    begin

    a[i, j]: = random (99) + 1;

    write (a[i, j], ' ') ;

    if a[i, j] < min then min: = a[i, j];

    if a[i, j] > max then max: = a[i, j];

    end;

    writeln;

    writeln ('Разность максимального и минимального элемента массива равна: ', max - min) ;

    end.

    Если что не понятно - спрашивай.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан двумерный массив сосстоящий из 4 строк и 5 стобцов и заполненный случайным образом целыми числами от 1 до 100 ... Найти разность ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
1. Дан массив 1 2 3 4 5 6 7 8 7 0 - 8 - 4 2 16 - 10 2 А Определите: А) размерность массива; Б) значение элемента А[3]; В) значение максимального элемента массива; Г) индекс первого отрицательного элемента массива;
Ответы (1)
1. Дан одномерный массив размерностью 10, заполненный целыми числами, введенными с клавиатуры, и величина N. Отрицательные элементы заменить на N. Измененный массив вывести на экран одной строкой. 2.
Ответы (1)
Visual basic 1. Сформировать одномерный массив из восьми вещественных значений. 2. Сформировать двумерный массив из А строк и В столбцов. 3. Составить программу для определения максимального и минимального элементов двумерного массива. 4.
Ответы (1)