Задать вопрос
22 июня, 18:42

Написать программу, которая выводит пример на вычитание (в пределах 100), запрашивает ответ пользователя, проверяет ответ и выводит сообщение "Правильно!" или "Вы ошиблись" и правильный результат

+5
Ответы (1)
  1. 22 июня, 21:40
    0
    program ProgramXY;

    const n=100;

    var inputText : integer;

    begin Randomize;

    var x : = Random (n) + 1;

    var y : = Random (n) + 1;

    var z : = x - y;

    writeln ('Решите пример: ', x, ' - ', y, ' = ') ;

    readln (inputText) ;

    if inputText = z then writeln ('Правильно!')

    else writeln ('Вы ошиблись! Правильный ответ: ', z)

    end.

    Где-то так это выглядит на Паскале. Ошибки не обработаны, так что, если вместо числа ввести строку - программа умрет по исключению.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу, которая выводит пример на вычитание (в пределах 100), запрашивает ответ пользователя, проверяет ответ и выводит ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составьте программу которая выводит на экран пример на умножение двух целых чисел, запрашивает ответ пользователя. проверяет его и выводит соответсвующиеся сообщения : "Правильно!" либо "Вы ошиблись". а также правильный результат
Ответы (1)
Составьте программу, которая выводит пример на умножени е двух однозначных чисел, запрашивает ответ пользователя, проверяет его и выводи т сообщение "Правильно!" или "Вы ошиблись" и правильны й результат в паскале
Ответы (1)
1. Написать командный файл, который: • запрашивает у пользователя текущий курс доллара • запрашивает у пользователя сумму в рублях • выводит сумму в долларах по текущему курсу
Ответы (1)
3. Написать программу, которая запрашивает ввод целого числа в переменную B и выводит это число на экран. Проверить правильность работы программы на числах 1, - 5, 256, 10455. 4.
Ответы (1)
Задание 1 Напишите программу, которая спрашивает у пользователя два слова и выводит их разделёнными запятой. Задание 2 Напишите программу, которая запрашивает три целых числа a, b и x и выводит True, если x лежит между a и b, иначе - False.
Ответы (1)