Задать вопрос
11 августа, 12:24

напишите программу для паскаля.

условие: обменять значения двух переменных, используя третью (буферную) переменную

+1
Ответы (1)
  1. 11 августа, 15:38
    0
    var

    a, b, buf:real;

    begin

    write ('a = ') ; readln (a) ;

    write ('b = ') ; readln (b) ;

    buf : = a;

    a : = b;

    b : = buf;

    writeln ('a = ', a) ;

    writeln ('b = ', b) ;

    end.

    / / без буферной переменной

    var

    a, b:real;

    begin

    write ('a = ') ; readln (a) ;

    write ('b = ') ; readln (b) ;

    a : = a + b;

    b : = a - b;

    a : = a - b;

    writeln ('a = ', a) ;

    writeln ('b = ', b) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «напишите программу для паскаля. условие: обменять значения двух переменных, используя третью (буферную) переменную ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике