Задать вопрос
7 декабря, 11:07

написать программу поиска значения максимального элемента массива

+5
Ответы (1)
  1. 7 декабря, 12:09
    0
    Const n=10;

    Var a:array[1 ... n] of integer; i, max:integer;

    Begin

    randomize;

    for i:=1 to n do a[i]:=random (201) - 100;

    for i:=1 to n do write (a[i],' ') ;

    writeln;

    max:=a[1];

    for i:=2 to n do

    if a[i]>max then max:=a[i];

    writeln ('max=', max) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «написать программу поиска значения максимального элемента массива ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
1. Дан массив 1 2 3 4 5 6 7 8 7 0 - 8 - 4 2 16 - 10 2 А Определите: А) размерность массива; Б) значение элемента А[3]; В) значение максимального элемента массива; Г) индекс первого отрицательного элемента массива;
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
написать программу нахождения максимального числа, где должны быть: 1. ввод 10 чисел с клавиатуры 2. их перебор с нахождением максимального элемента 3. вывод значения максимального элемента в текстовый файл (программа должна его создать)
Ответы (1)
Заменить значение каждого элемента каждой строки массива А на значение соответствующего элемента соответствующего столбца массива В (1-й элемент 1-й строки массива А на 1-й элемент 1-го столбца массива В, 2-й элемент 1-й строки массива А на 2-й
Ответы (1)