Задать вопрос
26 июня, 01:27

В данной действительной квадратной матрице порядка n найти сумму элементов строки, в которой расположены элемент с наименьшим значением. Предполагается что такой элемент единственный.

+2
Ответы (1)
  1. 26 июня, 02:38
    0
    var

    matr: array[1 ... 3, 1 ... 3] of integer;

    i, j, sum, min, min_ind: integer;

    begin

    for i : = 1 to 3 do

    for j : = 1 to 3 do

    matr[i, j] : = random (10) + 1;

    for i : = 1 to 3 do

    begin

    for j : = 1 to 3 do

    Write (matr[i, j], ' ') ;

    Writeln;

    end;

    min : = matr[1, 1];

    for i : = 1 to 3 do

    for j : = 1 to 3 do

    if matr[i, j] < min then

    begin

    min : = matr[i, j];

    min_ind : = i;

    end;

    sum : = 0;

    for j : = 1 to 3 do

    sum : = sum + matr[min_ind, j];

    Writeln ('Сумма твоих элементов=', sum) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В данной действительной квадратной матрице порядка n найти сумму элементов строки, в которой расположены элемент с наименьшим значением. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Паскаль! Дан целочисленный квадратный массив 4 х 4. Найти строки с наибольшей суммой элементов. Вывести на печать номер строки и сумму ее элементов. Предполагается, что такая строка единственна.
Ответы (1)
Дан целочисленный прямоугольный массив 6x10. Опишите в программе "ПаскальАВС" алгоритм вычисления суммы минимальных элементов из каждой строки. Напечатать значение этой суммы. Предполагается, что в каждой строке минимальный элемент единственный.
Ответы (1)
Задан двумерный массив, имеющий N строк и M столбцов. Определите, является ли строка номер N1 равной строке номер N2. Если ДА - вывести Yes и сумму элементов строки N1. Если НЕТ - вывести No и сумму элементов строки N2.
Ответы (1)
В квадратной матрице порядка N найти в каждом столбце отдельно количество элементов, превышающих число 5.
Ответы (1)
Заменить значение каждого элемента каждой строки массива А на значение соответствующего элемента соответствующего столбца массива В (1-й элемент 1-й строки массива А на 1-й элемент 1-го столбца массива В, 2-й элемент 1-й строки массива А на 2-й
Ответы (1)