Задать вопрос
11 сентября, 13:03

Найти среднее арифметическое цифр натурального числа n. (использовать частично стандартный алгоритм накопления суммы)

+5
Ответы (1)
  1. 11 сентября, 15:32
    0
    var i, n, sum:integer;

    begin

    readln (n) ;

    while n>0 do begin

    i:=i+1;

    sum:=sum + (n mod 10) ;

    n:=n div 10;

    end;

    writeln (sum/i) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти среднее арифметическое цифр натурального числа n. (использовать частично стандартный алгоритм накопления суммы) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Нужно определить что в введеном числе 24 часовой формат или 12 часовой формат и составить код в с++ Задача такое: №1 Input (стандартный ввод) Output (вывод) 11:00 24-часовый формат 23:00 №2 Input (стандартный ввод) Output (вывод) 09:20 12-часовый
Ответы (1)
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)
A+B Ограничение времени 2 секунды Ограничение памяти 64Mb Ввод стандартный ввод или input. txt Вывод стандартный вывод или output. txt Даны два числа A и B. Вам нужно вычислить их сумму A+B.
Ответы (1)
Составьте алгоритм вычисления суммы целых чисел x, y, z. Определить четная ли она, если четная, то найти среднее арифметическое значение данных чисел, если нечетная, то найти их среднее геометрическое значение.
Ответы (1)