Задать вопрос
10 мая, 04:21

надо составить программу в паскале, в которой надо найти процент от заданного числа

+5
Ответы (1)
  1. 10 мая, 08:09
    0
    Var

    q: Single; / / Результат. Если число будет больше, то указать Double

    i: Single; / / Число из которого необходимо получить результат. Если число будет больше, то указать Double

    p: Single; / / Процент. Если процент будет всегда целым числом, то указать Byte

    begin

    writeln ('Введите число = > ') ;

    read (i) ;

    writeln ('Введите процент, который хотите расcчитать из введенного числа = > ') ;

    read (p) ;

    while p < 0 do

    begin

    writeln ('Процент не может быть меньше нуля, введите новое значение = > ') ;

    read (p) ;

    end;

    q: = (i / 100) * p;

    writeln ('Ваш результат из числа = > ', i, ', ', p, '% = ', q) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «надо составить программу в паскале, в которой надо найти процент от заданного числа ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Сформировать текст заданной длины, состоящий из 2 символов А и В. 2. Найдите количество символов заданного числа 25 3. Написать программу обращения заданного слова (вывести символы строки в обратном порядке). (слово привет) 4.
Ответы (1)
1. Составьте алгоритм вычисления суммы квадратов цифр, заданного трехзначного числа. 2. Составить алгоритм вычисления разности кубов цифр, заданного восьмизначного числа. 3.
Ответы (1)
Помогите томата вить программу на паскале Используя подпрограммы-процедуры составить программу для формирования массива элементы которого являются цифры заданного числа n
Ответы (1)
1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
Ответы (1)
С клавиатуры вводят слово и символ. составить программу, которая: а) проверяет есть ли в этом слове заданный символ б) определяет позицию заданного символа в) подсчитывает количество вхождений заданного символа.
Ответы (1)