Задать вопрос
14 марта, 20:47

Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите разность наибольшего элемента и среднего арифметического элементов этого массива. Выведите на экран исходный массив и полученную разность.

+3
Ответы (1)
  1. 14 марта, 23:49
    0
    Program pr;

    uses crt;

    Var a:array[1 ... 10] of integer;

    i, max:integer;

    s:real;

    Begin

    for i:=1 to 10 do Begin a[i]:=random (100) ; Write (a[i],'; ') ; end;

    Writeln;

    max:=abs (a[1]-a[2]) ;

    for i:=1 to 9 do

    if abs (a[i]-a[i+1]) >max then max:=abs (a[i]-a[i+1]) ;

    s:=0;

    for i:=1 to 10 do s:=s+a[i];

    s:=s/10;

    Writeln ('max=', max) ;

    Writeln ('среднее арифметическое=', s) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите разность наибольшего элемента и среднего арифметического ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите среднее арифметическое нечетных элементов массива с нечетными индексами. выведите на экран исходный массив и полученное среднее арифметическое. 2.
Ответы (1)
1. Задайте массив из 10 элементов с помощью датчика целых случайных чисел. Найдите сумму четных элементов массива. Выведите на экран исходный массив и полученную сумму. 2. Дан массив В (n). Определите произведение элементов, кратных 3.
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1) напишите программу формирования массива размеров 5 х 5 с помощью датчика случайных чисел. замените в нем все четные значения элементов суммой индексов элементов главной диагонали.
Ответы (1)