Задать вопрос
10 мая, 02:57

составить программу в паскале как изменяетс ястепень найти сумму 2^3 + 2^5 + ... + 2^9

+4
Ответы (1)
  1. 10 мая, 04:08
    0
    uses crt;

    function step (n:integer) : integer;

    var p:integer;

    begin

    p:=2;

    repeat

    p:=p*2;

    n:=n-1;

    until n=1;

    step:=p;

    end;

    var

    a, sum, n:integer;

    begin

    n:=3;

    repeat

    sum:=sum+step (n) ;

    n:=n+2;

    until n>9;

    write (sum) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «составить программу в паскале как изменяетс ястепень найти сумму 2^3 + 2^5 + ... + 2^9 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите написать программу в паскале! Написать программу в паскале: В одномерном массиве из 10 целых чисел вычислить сумму четных чисел ...
Ответы (1)
Зачетная работа по информатике. 1. Написать программу вычисления площади прямоугольника (на паскале). 2. Написать программу вычесления ускорения тела (на паскале).
Ответы (1)
1) найти сумму первых k последовательных нечетных чисел. написать программу в паскале. 2) вывести на экран натуральные нечетные числа от 5 до 55. тоже паскаль 3) найти произведение последовательных натуральных чисел от n до m.
Ответы (1)
Помогите информатика 8 класс Задача 1. Составить программу определяющую длину фамилии и имени. Задача 2. Даны два слова. Составить программу определяющую произведение данных слов. Задача 3.
Ответы (1)
Задачи на массивы (в паскале) : 1. Найти количество нулей в одномерном массиве. 2. найти сумму элементов кратных 5. 3. найти сумму первых 5 элементов. 4. верно ли что в массиве есть два нуля. 5. найти сумму элементов из промежутка от А до В.
Ответы (1)