Задать вопрос
31 мая, 01:27

Вводятся величины X, Y целого типа. Разработать схему алгоритма для обмена значений величин. Необходимо использовать вспомогательную величину Т. Протестировать алгоритм для X=5 и Y=-11.

+2
Ответы (2)
  1. 31 мая, 01:38
    0
    Program Pr1;

    uses crt;

    var x, y, t:integer;

    Begin

    clrscr;

    readln (x, y) ;

    t:=x;

    x:=y;

    y:=t;

    writeln (x, y) ;

    end.
  2. 31 мая, 05:09
    0
    var

    x, y, t:integer;

    begin

    write ('x=') ;

    readln (x) ;

    write ('y=') ;

    readln (y) ;

    t:=x;

    x:=y;

    y:=t;

    writeln ('x=', x,' y=', y) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вводятся величины X, Y целого типа. Разработать схему алгоритма для обмена значений величин. Необходимо использовать вспомогательную ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Разработать схему алгоритма, который вводит массив из Nцелых чисел и выводит на экран этот же массив в прямом и обратном порядке. Протестировать алгоритм на произвольных массивах, состоящих из 1 числа, из 5 чисел, из 10 чисел. 2.
Ответы (2)
Вводятся х, у целого типа Написать программу для обмена значений величин. необходимо использовать вспомогательную величину Т
Ответы (1)
1. Разработать программу алгоритма для подсчета количества отрицательных чисел среди целых чисел a, b, c. Протестировать алгоритм для всех возможных случаев (когда количество отрицательных чисел равно 0, 1, 2 и 3). 2.
Ответы (1)
3. Написать программу, которая запрашивает ввод целого числа в переменную B и выводит это число на экран. Проверить правильность работы программы на числах 1, - 5, 256, 10455. 4.
Ответы (1)
написать программу для ввода значения величины X целого типа, присваивания величине Y действительного типа значения 2.5, вычисления значения величины Z=X/Y и вывода значения величины Z. Протестировать алгоритм для X=5, X=0, X=-8.75
Ответы (1)