Задать вопрос
5 июня, 17:23

дан массив из пятнадцати элементов заполненный целыми числами в диапазоне от - 20 до 60. верно ли что максимальный элемент больше минимального более чем в два раза?

+4
Ответы (1)
  1. 5 июня, 19:38
    0
    type diapazon=-20 ... 60;

    var a: array [1 ... 15] of diapazon;

    i, max, min: integer;

    begin

    max:=1;

    min:=1;

    for i:=1 to 15 do

    begin

    readln (a[i]) ;

    if a[i]>max then max:=a[i];

    if a[i]
    end;

    if (max/min) > 2 then writeln ('Верно') else writeln ('Неверно') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «дан массив из пятнадцати элементов заполненный целыми числами в диапазоне от - 20 до 60. верно ли что максимальный элемент больше ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Дан одномерный массив размерностью 10, заполненный целыми числами, введенными с клавиатуры, и величина N. Отрицательные элементы заменить на N. Измененный массив вывести на экран одной строкой. 2.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
Дан массив А из N целочисленных элементов. 1) Заполнить массив А целыми числами в интервале[1,100] и вывести на экран. Найти максимальный четный элемент и вывести его на экран.
Ответы (1)