Задать вопрос
14 мая, 05:02

Ввести с клавиатуры 10 пар чисел, найти максимальное число в каждой паре и вывести его на экран. В работе использовать цикл с предусловием.

+4
Ответы (1)
  1. 14 мая, 08:32
    0
    var num1, num2, i:integer;

    nums:array [1 ... 10] of integer;

    begin

    i:=1;

    while (i < = 10) begin

    writeln ('Vvedite ', i,' paru!') ;

    write ('num 1: ') ; readln (num1) ;

    write ('num 2: ') ; readln (num2) ;

    if (num1 > = num2) then nums[i]:=num1 else nums[i]:=num2;

    i:=i+1;

    end;

    i:=1;

    while (i<=10) begin

    write (nums[i],' ') ;

    i:=i+1;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Ввести с клавиатуры 10 пар чисел, найти максимальное число в каждой паре и вывести его на экран. В работе использовать цикл с предусловием. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)
1. Прочитать с клавиатуры число n, затем прочитать n чисел и вывести на экран сумму тех из них, которые делятся на 3. 2. Прочитать с клавиатуры число n и вывести на экран сумму его четных цифр 3.
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
1) ввести с клавиатуры массив из n элементов вывести на экран элементы меньшие среднего арифметического всех элементов массива 2) ввести с клавиатуры массив из n элементов вывести на экран максимальный четный элемент и минимальный нечетный элемент
Ответы (1)
Составить программу вычисления суммы всех целых чисел от 0 до 100. 1 использовать цикл с предусловием. 2 использовать цикл с постусловием. 3 использовать цикл с параметром
Ответы (1)