Задать вопрос
20 июля, 12:02

помогите составить программу, проверяющею входит ли заданный символ в заданную строку, если входит, то вывести сколько раз

+3
Ответы (1)
  1. 20 июля, 15:21
    0
    var s:string;

    i:integer;

    c:char;

    begin

    readln (s) ;

    readln (c) ;

    while pos (c, s) 0 do begin

    inc (i) ;

    delete (s, pos (c, s),1) ;

    end;

    writeln (i) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «помогите составить программу, проверяющею входит ли заданный символ в заданную строку, если входит, то вывести сколько раз ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу которая удаляет из строки заданный символ (,) и вставляет в строку другой заданный символ (.)
Ответы (1)
Укажите алгоритмы устранения следующих ошибок: 1) Установить курсор на место вставки. 2) Нажать клавишу с нужным символом. Что это Лишний символ, пропущенный символ, неверный символ? 1) Установить курсор за ошибочным символом.
Ответы (1)
Во имя радостных мессий, помогите хоть одну задачку. Не шарю ( Дан массив из 15 элементов. Необходимо заполнить его с помощью оператора присваивания (случайными числами), вывести все элементы в строку, а затем вывести произведение всех элементов
Ответы (1)
Помогите информатика 8 класс Задача 1. Составить программу определяющую длину фамилии и имени. Задача 2. Даны два слова. Составить программу определяющую произведение данных слов. Задача 3.
Ответы (1)
Ввести строку с клавиатуры ввести символ с клавиатуры используя оператора ввода задать некоторую строку содержашая 15-25 символов определить длину строки вывести на экран сам символ и позицую в каторой он найден (также надо задать любое
Ответы (1)