Задать вопрос
7 декабря, 22:51

Школьный уровень

1. Найти все элементы массива b (n), большие или равные 0. На экран вывести номер элементов, их значения и количество.

2. В одномерном массиве целых чисел, содержащем 20 элементов, удалить k-ый элемент массива. Массив заполняется случайным образом числами от 0 до 50.

+2
Ответы (1)
  1. 8 декабря, 01:17
    0
    var

    b:array[1 ... 100] of integer;

    i, count, n:integer;

    begin

    randomize;

    write ('n = ') ; readln (n) ;

    for i : = 1 to n do

    begin

    b[i] : = random (51) - 25;

    writeln ('b[', i, '] = ', b[i]) ;

    end;

    writeln;

    count : = 0;

    for i : = 1 to n do

    if b[i] > = 0 then

    begin

    writeln ('b[', i, '] = ', b[i], ' > = 0') ;

    inc (count) ;

    end;

    writeln ('Count = ', count) ;

    end.

    / / вторая программа

    const

    n = 20;

    var

    a:array[1 ... n] of integer;

    i, k:integer;

    begin

    randomize;

    writeln ('Исходный массив: ') ;

    for i : = 1 to n do

    begin

    a[i] : = random (51) ;

    write (a[i], ' ') ;

    end;

    writeln;

    write ('k = ') ; readln (k) ;

    if (k > n) or (k < 1) then

    begin

    writeln ('элемента с таким индексом нет') ;

    readln;

    Exit;

    end;

    for i : = k to n - 1 do

    a[i] : = a[i + 1];

    a[n] : = 0;

    writeln ('Измененный массив:') ;

    for i : = 1 to n - 1 do

    write (a[i], ' ') ;

    readln;

    writeln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Школьный уровень 1. Найти все элементы массива b (n), большие или равные 0. На экран вывести номер элементов, их значения и количество. 2. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
написать программу на Pascal - В одномерном массиве целых чисел, содержащем 20 элементов, удалить k-ый элемент массива. Массив заполняется случайным образом числами от 0 до 50.
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
1. заполните одномерный массив B1 размерностью в N (< 30 задает пользователь при выполнении программы) элементов так, чтобы каждый элемент с четным номером был равен половине своего номера, а каждый элемент с нечетным номером - количеству элементов
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)