Задать вопрос
27 августа, 05:07

Паскаль. 1) Определите, сколько чисел, введённых пользователем делятся на 3 без остатка. Ввод чисел пользователем заканчивается после ввода цифры 0. 2) Найдите сумму цифр числа, меньших 5. Например, для числа 715245 это будет 1+2+4=7. Написать блок-схему и программу.

+4
Ответы (2)
  1. 27 августа, 06:37
    0
    var

    C, count:integer;

    begin

    write ('Введите число ') ;

    count : = 0;

    readln (C) ;

    while C 0 do

    begin

    if (C mod 3) = 0 then

    inc (count) ;

    write ('Введите число ') ;

    readln (C) ;

    end;

    writeln ('Count = ', count) ;

    readln;

    end.

    //вторая программа

    var

    C, Summ:integer;

    begin

    write ('C = ') ;

    Summ : = 0;

    readln (C) ;

    while C 0 do

    begin

    if (C mod 10) < 5 then

    inc (Summ, C mod 10) ;

    C : = C div 10;

    end;

    writeln ('Summ = ', Summ) ;

    readln;

    end.
  2. 27 августа, 08:57
    0
    1)

    program ABC;

    var num, count:integer;

    begin

    readln (num) ;

    while num0 do

    begin

    if (num mod 3) = 3 then

    count:=count+1

    end;

    writeln (count)

    end.

    2)

    program ABC;

    var num, sum:integer;

    begin

    readln (num) ;

    while num0 do

    begin

    if (num mod 10) < 5 then

    sum:=sum+num mod 10;

    num: = num div 10

    end;

    writeln (sum)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль. 1) Определите, сколько чисел, введённых пользователем делятся на 3 без остатка. Ввод чисел пользователем заканчивается после ввода ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
3. Написать программу, которая запрашивает ввод целого числа в переменную B и выводит это число на экран. Проверить правильность работы программы на числах 1, - 5, 256, 10455. 4.
Ответы (1)
Помогите! прошу ... Составьте блок-схему алгоритма решения задачи: Для введенных целых положительных и отрицательных чисел найдите произведение половины каждого числа. Условием окончания ввода чисел является ввод.
Ответы (1)
1. составьте блок-схему алгоритма и программу вычисления в матрице B (N, N) количества элементов, меньших 5 2. Составьте без использования клавиатуры программу ввода матрицы С. 1 2 3 4 5 6 С = 0 1 2 3 4 5 0 0 1 2 3 4
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)