Задать вопрос
17 августа, 15:15

Решить задачи в паскале.

1) В двузначное число вписать ноль в середину и получить трехзначное число

2) Задано двузначное число. Чему равна первая цифра числа?

+4
Ответы (2)
  1. 17 августа, 15:54
    0
    1)

    Var x:inreger;

    Begin

    readln (x) ;

    x: = ((x div 10) * 100) + (x mod 10) ;

    writeln (x) ;

    End.

    2)

    Var x:integer;

    Begin

    readln (x) ;

    x:=x div 10;

    writeln (x) ;

    End.
  2. 17 августа, 19:04
    0
    Program dvyzna4;

    var i:integer;

    begin

    repeat

    writeln ('Введите число=') ; readln (i) ;

    until (i>=10) and (i<=99) ;

    writeln ('1-ая цифра=', i div 10) ;

    writeln ('Трехзначное=', i div 10,'0', i mod 10) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Решить задачи в паскале. 1) В двузначное число вписать ноль в середину и получить трехзначное число 2) Задано двузначное число. Чему равна ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. В двухзначное число вписать ноль в середину и получить трехзначное число. 2. Задано пятизначное число. Найдите цифры и сумму цифр пятизначного числа. 3. Робинзон Крузо провёл на острове f дней. Сколько полных недель он пробыл на острове?
Ответы (1)
На паскале нужно решить задачи 1. Задано трехзначное число. Составьте программу, с помощью которой определите произведение кубов цифр этого числа. 2. Задано трехзначное число.
Ответы (1)
Напишите программы для решения задач. Используйте операция div и mod. 1. Задано двузначное число. Найдите среднее арифметическое цифр числа. 2. Задано двузначное число. Найдите разность между количеством десятков и единиц.
Ответы (2)
Автомат получает на вход нечётное число X. По этому числу строится трёхзначное число Y по следующим правилам. 1. Первая цифра числа Y (разряд сотен) - остаток от деления X на 4. 2. Вторая цифра числа Y (разряд десятков) - остаток от деления X на 3.
Ответы (1)
1. Дано двузначное число. Определить: a. какая из его цифр больше, первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число. Определить, равен ли квадрат этого числа учетверённой сумме кубов его цифр.
Ответы (1)