Задать вопрос
20 ноября, 01:01

дано натурально 4 значное число, верно ли что число заканчивается на цифру А (а вводится с клавиатуры)

+5
Ответы (1)
  1. 20 ноября, 03:42
    0
    на си (с++)

    #include

    void main () {

    int a;

    int x;

    cin>>x; //число на которое должно закончитьс

    cin>>a; //число которое вводишь

    int b, c, d;

    b=a%1000; //остаток от деления на 1000

    d=b%100; //остаток от остатка деления на 100

    c=d%10; //само число

    if (c==x) cout<<"Верно"; else cout<<"Не верно";

    }

    если на паскале тольок вместо % ставите mod и вместо cout write

    и в скобках а так в принципе все
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «дано натурально 4 значное число, верно ли что число заканчивается на цифру А (а вводится с клавиатуры) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Напишите программу на паскале) 1. С клавиатуры вводится 3-хзначное число. Определить какая из его цифр больше. 2. С клавиатуры вводится 3-хзначное число. Определить является ли произведение его цифр 3-хзначным числом. 3.
Ответы (1)
1. дано натурально четырехзначное число. определить цифры этого числа (K, L. M. N) и выяснить можно ли построить ромб со сторонами K, L. M. N. в паскале АВС. 2. дано натурально число N вычислить куб суммы этого числа
Ответы (1)
Дано натуральное число. Определить: а) сколько раз в нем встречается цифра а; б) количество его цифр, кратных z (значение z вводится с клавиатуры; z 2, 3, 4) ; в) сумму его цифр, больших a (значение a вводится с клавиатуры; 0 a 8) ;
Ответы (1)