Задать вопрос
26 февраля, 21:20

Введите с клавиатуры массив с оценками 10 учеников. составьте программу для вывода по номеру ученика его оценку

+5
Ответы (2)
  1. 26 февраля, 21:47
    0
    var a:array [1 ... 10] of integer;

    i, n:integer;

    begin

    randomize;

    for i:=1 to 10 do begin

    a[i]:=random (5) + 1;

    end;

    readln (n) ;

    case n of

    1:writeln (a[1]) ;

    2:writeln (a[2]) ;

    3:writeln (a[3]) ;

    4:writeln (a[4]) ;

    5:writeln (a[5]) ;

    6:writeln (a[6]) ;

    7:writeln (a[7]) ;

    8:writeln (a[8]) ;

    9:writeln (a[9]) ;

    10:writeln (a[10]) ;

    end;

    end.
  2. 27 февраля, 01:16
    0
    Program z;

    var A:array [1 ... 10] of integer;

    i, n:integer;

    Begin

    for i:=1 to 10 do

    read (A[i]) ;

    writeln ('введите номер ученика') ;

    readln (n) ;

    writeln ('оценка ученика - ', A[n]) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Введите с клавиатуры массив с оценками 10 учеников. составьте программу для вывода по номеру ученика его оценку ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
Составте программу, вычисления суммы цифр трёхзначного числа а. Значение а введите с клавиатуры Пример ввода: 375 Пример вывода: Сумма цифр числа 375 равна 15 2) Составте программу, которая получает 'перевёртыш' трёхзначного числа а.
Ответы (1)
Program a2; var n, i, min, max, x:integer; begin Writeln ('Введите колицество человек в классе:') ; Readln (n) ; Writeln ('Введите рост 1 ученика:') ; readln (x) ; min:=x; max:=x; for i:=2 to n do begin Writeln ('Введите рост ', i,' ученика:') ;
Ответы (1)
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)