Задать вопрос
28 декабря, 03:46

Написать на Паскале программу нахождения суммы, произведения и среднего значения элементов массива, кол-во элементов ввести в программе.

+5
Ответы (1)
  1. 28 декабря, 04:37
    0
    var

    s, p:int64;

    i, kol, m:integer;

    a:array of integer;

    begin

    readln (kol) ;

    s:=0;

    p:=0;

    m:=0;

    setlength (a, kol) ;

    for i : = 1 to kol do

    begin

    read (a[i]) ;

    s:=s+a[i];

    p:=p*a[i];

    end;

    m:=s div kol;

    writeln ('Сумма ', s) ;

    writeln ('Произведение', p) ;

    writeln ('Среднее значение', m) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать на Паскале программу нахождения суммы, произведения и среднего значения элементов массива, кол-во элементов ввести в программе. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)
Составьте программу в Паскале для поиска: a) суммы положительных элементов массива от а от 1 до 100, введенных с клавиатуры b) произведения отрицательных элементов массива а от 1 до 100 c) количества нулевых элементов массива с сотней элементов
Ответы (1)
Дана программа нахождения суммы всех элементов массива. Изменить программу таким образом, чтобы: a) массив состоял из 15 элементов вещественного типа; b) значения элементов массива должны меняться в интервале от 0 до 5;
Ответы (1)