Задать вопрос
13 августа, 18:36

Написать программу на языке Паскаль. Вводятся размер и элементы одномерного массива A (N), состоящего из целых чисел. Подсчитать сумму простых чисел, оканчивающихся на 3. Результат вывести на экран.

+3
Ответы (1)
  1. 13 августа, 20:18
    0
    uses crt;

    Var a:array [1 ... 100] of integer; i, n, s: integer;

    Begin

    Writeln ('Введите размер массива') ; readln (n) ;

    For i:=1 to n do begin

    writeln ('Введите элемент массива номер ', i) ; read (a[i]) ;

    end;

    For i:=1 to n do

    if a[i] mod 10=3 then s:=s+a[i];

    Writeln ('Сумма = ', s) ;

    end.

    Написано через PascalABC. Если используете другой паскаль вместо первой строчки пишите "Program 123;"
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу на языке Паскаль. Вводятся размер и элементы одномерного массива A (N), состоящего из целых чисел. Подсчитать сумму ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Заполнить и вывести на экран массив 5 х 10 случайных целых чисел в диапазоне от 1 до 10. 2) Найти сумму элементов одномерного массива с k1-го по k2-ой, где k1 и k2 вводятся с клавиатуры. Сделать проверку корректности их ввода.
Ответы (1)
Сделать программу в Pascal. 1. Организуйте ввод и вывод одномерного массива в строку, в столбец. 2. Найдите произведение ненулевых элементов одномерного массива. 3.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Написать программу к задаче: Завести в программе массив под именем TOR из 7 элементов, элементы массива TOR[2,1,2,1,2,1,2], вывести элементы массива на экран и подсчитать сумму элементов массива. Выучить определения массива.
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)