Задать вопрос
3 марта, 08:23

Даны 3 числа, написать программу подсчитывающую количество отрицательных чисел и сумму неотрицательных чисел

+3
Ответы (1)
  1. 3 марта, 12:23
    0
    Program p2;

    Var a, b, c:integer;

    kolichestvo:byte;

    summa:integer;

    Begin

    kolichestvo:=0;

    summa:=0;

    Readln (a) ;

    If a<0 then

    kolichestvo:=kolichestvo+1 else

    summa:=summa+a;

    Readln (b) ;

    If b<0 then

    kolichestvo:=kolichestvo+1 else

    summa:=summa+b;

    Readln (c) ;

    If c<0 then

    kolichestvo:=kolichestvo+1 else

    summa:=summa+c;

    Writeln ('Количество отрицательных = ', kolichestvo) ;

    Writeln ('Сумма положительных = ', summa) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны 3 числа, написать программу подсчитывающую количество отрицательных чисел и сумму неотрицательных чисел ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Программу на с++ Даны натуральное число n, действительные числа а1, ..., аn. Преобразовать последовательность al, ..., аn, расположив вначале отрицательные члены, а затем-неотрицательные.
Ответы (1)
Даны целые числа a, b и c. Написать программу подсчитывающую количество положительных и количество отрицательных чисел среди данных. Входные данные - 2 4 - 1 выходные 2 1
Ответы (1)
Даны целые числа a, b и с. написать программу подсчитывающую кол-во положительных и кол-во отрицательных чисел среди данных. входные данные - 2 4 - 1 выходные 2 1. (язык программирования Паскаль АБС)
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Даны целые числа а в с написать программу, подсчитывающую сумму тех чисел из данных, которые больше 0
Ответы (1)