Задать вопрос
4 апреля, 10:52

Нарисовать N концентрических окружностей с минимальны радиусом r и максимальным радиусом R c центром с координатами X и Y. N, r, R, X, Y вводятся с клавиатуры. pascal abc

+5
Ответы (1)
  1. 4 апреля, 12:05
    0
    Program Krugi;

    Uses Crt, GraphABC;

    var i, X, Y, RMax, RMin, N:integer;

    begin

    clrscr;

    write ('Количество окружностей:') ;

    readln (N) ;

    write ('Введите X:') ;

    readln (X) ;

    write ('Введите Y:') ;

    readln (Y) ;

    write ('Введите Максимальный радиус:') ;

    readln (RMax) ;

    write ('Введите Минимальный радиус:') ;

    readln (RMin) ;

    SetWindowSize (800,600) ;

    for i:=RMax downto RMin do

    begin

    if n=0 then break;

    if (n=1) then circle (X, Y, RMin) else

    circle (X, Y, i) ;

    i:=i-5;

    n:=n-1;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Нарисовать N концентрических окружностей с минимальны радиусом r и максимальным радиусом R c центром с координатами X и Y. N, r, R, X, Y ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить задачи! 1. Дан массив размера 10, числовые значения которого вводятся с клавиатуры. Вывести максимальный элемент данного массива и его номер. 2. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.
Ответы (1)
Задания по Pascal №1 найти все двузначные числа, такие, что сумма цифр равна A, а само число делится на B. A и B вводятся с клавиатуры. №2 найти сумму всех чисел из промежутка от A до B, кратных 5. A и B вводятся с клавиатуры.
Ответы (1)
1. Напишите программу вычисления корней квадратного уравнения, если с клавиатуры, если коэффициенты вводятся с клавиатуры (a, b, c) 2. Координаты 2-х точек плоскости вводятся с клавиатуры.
Ответы (1)
1) C клавиатуры вводятся 10 чисел. Найти сумму тех из них, которые больше 10. 2) Найти произведение двузначных нечетных чисел. 3) С клавиатуры вводятся N чисел.
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)