Задать вопрос
23 июля, 22:55

Написать программу, которая вводит n элементов массива и вычисляет сумму первого и максимального элемента массива

+5
Ответы (2)
  1. 23 июля, 23:39
    0
    uses crt;

    var

    a:array [1 ... 1000] of integer;

    max, i, k:integer;

    begin

    write ('Введи количество элементов массива: ') ; read (k) ;

    for i:=1 to k do

    begin

    a[i]:=random (100) - 50;

    write (a[i]:4) ;

    end;

    writeln;

    max: = a[1];

    for i:=1 to k do

    if a[i]>max then max:=a[i];

    writeln ('Максимальный элемент: ', max) ;

    writeln ('Сумма первого и максимального элементов: ', max+a[1])

    end.
  2. 24 июля, 00:37
    0
    Случайным образом вводятся целые числа от 0 до 999.

    max - максимальный элемент массива

    i - цикловая переменная.

    var

    a : array [1 ... 100] of integer;

    max, i, n : integer;

    begin

    readln (n) ;

    for i : = 1 to n do

    a [ i ] : = random (1000) ;

    max : = a [ 1 ];

    for i : = 2 to n do

    if a [ i ] > max then

    max : = a [ i ];

    writeln (max + a [ 1 ])

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу, которая вводит n элементов массива и вычисляет сумму первого и максимального элемента массива ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
1. Дан массив 1 2 3 4 5 6 7 8 7 0 - 8 - 4 2 16 - 10 2 А Определите: А) размерность массива; Б) значение элемента А[3]; В) значение максимального элемента массива; Г) индекс первого отрицательного элемента массива;
Ответы (1)
Написать программу которая вводит n элементов массива и вычисляет произведение первого и последнего элемента массива
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)