Задать вопрос
23 декабря, 11:51

Дана: квадратная матрица Найти: наибольшее и наименьшее значения главной диагонали.

+2
Ответы (2)
  1. 23 декабря, 13:37
    0
    uses crt;

    var

    a:array [1 ... 1000,1 ... 1000] of integer;

    i, j, max, min, k:integer;

    begin

    clrscr; randomize;

    write ('Введи количество столбцов/строк матрицы: ') ; read (k) ;

    for i:=1 to k do

    begin

    for j:=1 to k do

    begin

    a[i, j]:=random (100) - 50;

    write (a[i, j]:4) ;

    end;

    writeln;

    end;

    max:=1; min:=1;

    for i:=2 to k do

    if a[i, i]>max then max:=a[i, i]

    else

    if a[i, i]
    writeln ('Наибольшее значение главной диагонали: ', max) ;

    write ('Наименьшее значение главной диагонали: ', min) ;

    end.
  2. 23 декабря, 14:27
    0
    var

    a:array [1 ... 100,1 ... 100] of integer;

    i, j, max, min, n:integer;

    begin

    write ('Введите порядок матрицы: ') ; readln (n) ;

    randomize;

    for i:=1 to n do begin

    for j:=1 to n do begin

    a[i, j]:=random (25) - 9;

    write (a[i, j]:4) ;

    end;

    writeln;

    end;

    max:=a[1,1];

    min:=a[1,1];

    for i:=2 to n do

    if a[i, i]>max then max:=a[i, i] else

    if a[i, i]
    writeln ('Max: ', max) ;

    writeln ('Min: ', min) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана: квадратная матрица Найти: наибольшее и наименьшее значения главной диагонали. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
23. Дана действительная квадратная матрица порядка n. Выяснить, верно ли, что наибольшее из значений элементов главной диагонали больше, чем наименьшее из значений элементов побочной диагонали.
Ответы (1)
Дана матрица размерностью nxn найти Дана матрица размерностью nxn найти минимальный элемент среди элементов расположенных над главной диагональю матрицы.
Ответы (1)
Дана квадратная матрица действительных чисел. Найти сумму модулей элементов, расположенных выше главной диагонали.
Ответы (1)
Pascal. Дана целочисленная квадратная матрица. Найти в каждой строке наибольший элемент и поменять его местами с элементом главной диагонали в этой же строке
Ответы (1)
Написать программу для решения следующей задачи: дана квадратная матрица порядка N. Заменить единицами все элементы, стоящие на главной диагонали и выше ее.
Ответы (1)