Задать вопрос
21 сентября, 05:45

Дано целое число, если оно делиться на 3 без остатка то увеличить его на 1; в противном случае уменьшить его на 2.

На паскале

+4
Ответы (2)
  1. 21 сентября, 07:17
    0
    var

    x: longint;

    begin

    write ('Введите число ') ;

    readln (x) ;

    if x mod 3 = 0 then / / Если х делится на 3, то ...

    x : = x + 1 / / Увеличиваем х на 1

    else / / В противном случае ...

    x : = x - 2; / / Уменьшаем на 2

    writeln ('Результат: ', x) ; / / Вывод полученого числа

    end.
  2. 21 сентября, 07:35
    0
    uses crt; {подключение модуля CRT}

    var

    x: integer; {описание переменных}

    begin {начало программы}

    writeln ('vvedi chislo: ') ; {вывод текста на экран}

    read (x) ; {чтение введеных данных}

    if (x mod 3 = 0) then x:=x+1 {условие}

    else x:=x-2; {если условие не выполняется}

    write ('rezultat: ', x) ; {вывод текста на экран}

    end. {конец программы}
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано целое число, если оно делиться на 3 без остатка то увеличить его на 1; в противном случае уменьшить его на 2. На паскале ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано число. Если оно делится на 11, то уменьшить ч Дано число. Если оно делится на 11, то уменьшить число в 11 раз, в противном случае уменьшить число на 11. исло в 11 раз, в противном случае уменьшить число на 11.
Ответы (1)
Дано целое число. Если оно кратно 5, то вывести на экран сообщение: "Да" и уменьшить число в 5 раз. В противном случае вывести на экран сообщение "Нет" и при этом число увеличить в 5 раз.
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Написать программу которая определяет: если целое число M делится на целое число N, то на экране выводит часть деления, в противном случае выводится сообщение "M и N нацело не делиться" в pascal
Ответы (2)
Дано число. Если оно не делится на 5, то увеличить число в 5 раз, в противном случае уменьшить число в 5 раз.
Ответы (1)