Задать вопрос
4 марта, 22:54

Дано число А. Определить, является ли оно простым (простое это натуральное число имеющие ровно два различных натуральных делителя: пшеницы и само себя)

+3
Ответы (1)
  1. 5 марта, 02:01
    0
    Var a, i, k:integer;

    begin

    readln (a) ;

    for i:=2 to a-1 do

    if (a mod i) = 0 then k:=k+1;

    if k=0 then writeln ('Простое')

    else writeln ('Сложное') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано число А. Определить, является ли оно простым (простое это натуральное число имеющие ровно два различных натуральных делителя: пшеницы ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Условие: Дано натуральное число. Проверить, является ли оно простым. Примечание: простым называется натуральное число, которое имеет ровно два различных натуральных делителя: единицу и само это число.
Ответы (2)
1) Запишите внутреннее представление десятичного числа - 104 в 8-разрядной ячейке памяти компьютера Ниже запишите ответ - только само число, без пояснений 2) Запишите внутреннее представление десятичного числа 79 в 8-разрядной ячейке памяти
Ответы (1)
Найдите наименьшее натуральное число, у которого ровно 32 делителя (включая 1 и само число 32). Например, у числа 6 четыре делителя: 1, 2, 3, 6. В качестве ответа укажите одно натуральное число.
Ответы (1)
1). Натуральное число, на которое заданное натуральное число делится без остатка! 2). Натуральное число, имеющее только два делителя: единицу и само число 3). Два числа, произведение которых равно 1 помогите плииз) оч надо)
Ответы (1)
1. Дано натуральное число. Верно ли, что сумма его цифр есть четное число, а само число не превышает b? 2. Дано натуральное число. Верно ли, что сумма его цифр больше m а само число делится на n?
Ответы (1)