Задать вопрос
30 марта, 12:56

В программе паскаль составить программу, выводящую на экран ряд чисел Фибоначчи.

Фибон а ччи ч и сла, элементы числовой возвратной последовательности 1, 1, 2, 3, 5, 8, ... (ряда Фибоначчи), в которых каждый последующий член равен сумме двух предыдущих.

+3
Ответы (1)
  1. 30 марта, 14:44
    0
    Program Fibonacci;

    Uses Crt;

    var i, n:integer;

    {Итерационный метод вычисления чисел Фибоначчи}

    function fib_it (n:integer) : integer;

    var a, b, c, i:integer;

    begin

    a:=1; b:=1;

    if (n=1) or (n=2) then fib_it:=1

    else begin

    for i:=3 to n do

    begin

    c:=a+b;

    a:=b;

    b:=c;

    end;

    fib_it:=c;

    end;

    end;

    {main program}

    begin

    clrscr;

    write ('Введите n: ') ;

    readln (n) ;

    for i:=1 to n do write (fib_it (i),' ') ;

    readkey;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В программе паскаль составить программу, выводящую на экран ряд чисел Фибоначчи. Фибон а ччи ч и сла, элементы числовой возвратной ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Последовательность Фибоначчи определяется следующим образом: первые два члена последовательности равны 1, а каждый следующий равен сумме двух предыдущих. То есть числами Фибоначчи являются 1,1,2,3,5,8,13, ... Вводится натуральное число.
Ответы (1)
Решите задачу на Паскале. Числа Фибоначчи определяются как а (0) = 1, а (1) = 1, а (i) = a (i-1) + a (i-2). Найти десятое число Фибоначчи. Найти : a) N-ое число Фибоначчи б) Сумму первых N чисел Фибоначчи
Ответы (1)
Последовательность Фибоначчи образуется так: первый и второй члены последовательности равны 1, каждый следующий равен сумме двух предыдущих (1, 1, 2, 3, 5, 8, 13, ...).
Ответы (1)
Задача А Число Фибоначчи это числовая последовательность, в которой первые два числа единицы, а каждое последующее равно сумме двух предыдущих. Дано натуральное число N (2< N < 2*10^9). Найти два ближайших к нему числа Фибоначчи.
Ответы (1)
Последовательностью Фибоначчи называется последовательность чисел a0, a1, ..., an, ..., где a0 = 0, a1 = 1, ak = ak-1 + ak-2 (k > 1). Требуется найти N-е число Фибоначчи. Примечание. В программе запрещается использовать циклы.
Ответы (1)