Задать вопрос
3 сентября, 09:07

Напишите программу, которая принимает с клавиатуры число и превращает его в положительное, если оно отрицательное, либо в ноль во всех остальных случаях.

+2
Ответы (2)
  1. 3 сентября, 12:05
    0
    Program zadacha;

    var x:integer;

    Begin

    readln (x) ;

    if (x<0) then a:=abs (x)

    else a:=0;

    writeln (x) ;

    end.
  2. 3 сентября, 12:41
    0
    var a:integer;

    begin

    readln (a) ;

    if (a<0) then a:=a * (-1) else a:=0;

    writeln (a) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая принимает с клавиатуры число и превращает его в положительное, если оно отрицательное, либо в ноль во всех ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
1) Проверка условия и ветвление в алгоритме. Напишите программу которая анализирует введённое с клавиатуры число и выдает на экран: а) удвоенное значение числа, если число положительное; б) абсолютное значение числа, если число отрицательное.
Ответы (1)
Составить программу, которая запрашивает целое число, не равное нулю, сообщает, положительное оно или отрицательное. и при этом положительное число уменьшает в 2 раза, а отрицательное возводит в квадрат.
Ответы (1)
Напишите программу вывода на экран фразы "Число положительное", если введенное число положительное, и "Число отрицательное", если введенное число отрицательное.
Ответы (1)
Напишите программу которая увеличивает введенные число с клавиатуры в 3 раза если оно отрицательное и уменьшает на 8 если оно положительное
Ответы (1)