Задать вопрос
30 сентября, 19:16

напишите класс, который принимает с клавиатуры целое положительное число и, если оно как минимум трехзначное и положительное, уменьшает его на 1

+2
Ответы (1)
  1. 30 сентября, 23:11
    0
    type Cl = class

    a:integer;

    constructor Create (b:integer) ;

    procedure P;

    end;

    constructor Cl. Create (b:integer) ;

    begin

    a : = b;

    end;

    procedure Cl. P;

    begin

    if (a div 100 > 0) and (a > 0) then

    begin

    a : = a - 1;

    writeln ('new a = ', a) ;

    end;

    end;

    var

    Obj:Cl;

    a : integer;

    begin

    write ('a = ') ;

    readln (a) ;

    Obj : = Cl. Create (a) ;

    Obj. P;

    Readln;

    Obj. Destroy;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «напишите класс, который принимает с клавиатуры целое положительное число и, если оно как минимум трехзначное и положительное, уменьшает его ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Составить программу, которая запрашивает целое число, не равное нулю, сообщает, положительное оно или отрицательное. и при этом положительное число уменьшает в 2 раза, а отрицательное возводит в квадрат.
Ответы (1)
Напишите программу которая увеличивает введенные число с клавиатуры в 3 раза если оно отрицательное и уменьшает на 8 если оно положительное
Ответы (1)
С клавиатуры вводят целое число. Если оно положительное-увеличить его пять раз на два, иначе вывести сообщения, что оно не положительное
Ответы (1)
Играют двое. Первый участник игры называет произвольное целое положительное число, не превышающее десяти, то есть он может назвать число десять и всякое меньшее десяти положительное число.
Ответы (1)