Задать вопрос
28 июля, 14:52

Написать программу для вычисления N-ой степени числа a (aN). Протестировать программу для а) a=3 и N=4, б) a=2 и N=5.

+4
Ответы (1)
  1. 28 июля, 15:31
    -1
    Program zadacha;

    var a, n, i:integer;

    Begin

    read (a, n) ;

    for i:=1 to n do

    a:=a*a;

    writeln (a) ;

    end.

    или как вариант

    Program zadacha;

    var a, n:integer;

    Begin

    read (a, n) ;

    x:=exp (ln (a) * n) ;

    writeln (x) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу для вычисления N-ой степени числа a (aN). Протестировать программу для а) a=3 и N=4, б) a=2 и N=5. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
3. Написать программу, которая запрашивает ввод целого числа в переменную B и выводит это число на экран. Проверить правильность работы программы на числах 1, - 5, 256, 10455. 4.
Ответы (1)
1. Разработать схему алгоритма, который вводит массив из Nцелых чисел и выводит на экран этот же массив в прямом и обратном порядке. Протестировать алгоритм на произвольных массивах, состоящих из 1 числа, из 5 чисел, из 10 чисел. 2.
Ответы (2)
1. Разработать программу алгоритма для подсчета количества отрицательных чисел среди целых чисел a, b, c. Протестировать алгоритм для всех возможных случаев (когда количество отрицательных чисел равно 0, 1, 2 и 3). 2.
Ответы (1)
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)
Составить на паскале программу для вычисления суммы ряда:s=1+1/2+1/3+1/4 + ... 1/n число n вводится с клавиатуры. протестировать программу для n=1, n=2, n=4, n=6. правильность ответов проверить с помощью калькулятора.
Ответы (1)