Задать вопрос
16 мая, 16:40

Нужно расставить 4 введенных числа числа в порядке возрастания (Си)

+1
Ответы (1)
  1. 16 мая, 20:26
    0
    Вариант на C++. В данном случае отличия С от С + + минимальны, возможно, что тут только потребуется заменить cin на scanf и cout на printf. Ну и библиотеки.

    Числа вводятся в 4-ёх элементный массив, потом он сортируется и выводится.

    #include

    using std::cout;

    using std::cin;

    using std::endl;

    void sort (int*, const int) ;

    int main ()

    {

    const int arraySize = 4;

    int a[arraySize];

    cout << "Enter the four numbers: ";

    for (int i = 0; i < arraySize; i++)

    {

    cin >> a[i];

    }

    cout << endl;

    sort (a, arraySize) ;

    return 0;

    }

    void sort (int * a, const int size)

    {

    int temp, smallest;

    for (int i = 0; i < size - 1; i++)

    {

    smallest = i;

    for (int j = i + 1; j < size; j++)

    {

    if (a[smallest] > a[j])

    {

    smallest = j;

    }

    }

    temp = a[i];

    a[i] = a[smallest];

    a[smallest] = temp;

    }

    for (int i = 0; i < size; i++)

    {

    cout << a[i] << ' ';

    }

    cout << endl;

    }

    Опять вся табуляция позбивалась ...
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Нужно расставить 4 введенных числа числа в порядке возрастания (Си) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
составьте программу которая а) выполняет операцию сцепления трех введенных с клавиатуры символов б) выполняет операцию сцепления трех введенных с клавиатуры символов и выводит результат сравнения на экран.
Ответы (1)
Написать программу в Pascal Даны число A>0, числа x1, x2 ... Необходимо вводить числа x1, x2 ..., пока сумма модулей введенных чисел будет меньше A. Определить число введенных чисел. P.
Ответы (1)
Помогите решить 2 задачи ... 1) Вывести на экран квадрат наибольшего из 2 введенных чисел? 2) Вывести на экран корень наибольшего из 3 введенных чисел?
Ответы (1)
Составьте программу, которая: а) Определяет коды двух введённых с клавиатуры символов; б) Выполняет операцию сцепления трёх введённых с клавиатуры символов; на Pascal
Ответы (1)
Вводя два массива целых чисел до 10 в каждом. из введенных двух массивов построить третий массив, в котором элементы будут располагаться в порядке возрастания. Распечатать все 3 массива.
Ответы (1)