Задать вопрос
31 июля, 10:02

В линейном массиве посчитать количество элементов, значение которых совпадает с их

индексом.

+5
Ответы (2)
  1. 31 июля, 10:38
    0
    var a:array[1 ... 100]of integer; i, n, k:integer;

    begin

    readln (n) ;

    for i:=1 to n do

    readln (a[i]) ; k:=0;

    for i:=1 to n do begin

    if a[i]=i then k:=k+1; end;

    writeln (k) ;

    end.
  2. 31 июля, 12:32
    0
    Program P1;

    const n=10; (n - кол-во элементов массивa. можно изменить прямо в этой строке)

    type mas=array[1 ... n] of integer;

    var A:mas;

    k, i:integer;

    Begin

    k:=0; (k - кол-во элементов массива, значение которых совпадает с их индексом)

    for i: = 1 to n do

    Readln (A[i]) ;

    for i:=1 to n do

    if A[i]=i then k:=k+1;

    Writeln (k) ;

    end.

    P. S.

    Задача решена для Pascal!
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В линейном массиве посчитать количество элементов, значение которых совпадает с их индексом. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Перевести числа в десятичную систему счисления 11011,11 с индексом 2 ... 7512,35 с индексом 8 и число FAD, E8 с индексом 16
Ответы (1)
Дана последовательность целых чисел A1, A2, ..., An. Составьте программу, которая выводит разность произведения элементов с нечётным индексом и суммы элементов с чётным индексом.
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
1. Напишите алгоритм подсчета числа элементов, равных максимальному, в числовом массиве из 30 элементов. 2. Напишите алгоритм поиска трех последовательных элементов, сумма которых максимальна, в числовом массиве из 30 элементов.
Ответы (1)
Составить программу поиска элементов массива, значение которых совпадает с индексом.
Ответы (1)