Задать вопрос
22 сентября, 16:33

Найти все тройки натуральных чисел x, y, z из интервала от 1 до 20, для которых выполняется равенство x*x*y=z*z

+2
Ответы (1)
  1. 22 сентября, 19:22
    0
    For (x = 0; x < 20; x++)

    {

    for (y = 0; y < 20; y++)

    {

    for (z = 0; z < 20; z++)

    {

    if (x * x * y = = z * z)

    {

    printf ("%d %d %d", x, y, z) ;

    }

    }

    }

    }
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти все тройки натуральных чисел x, y, z из интервала от 1 до 20, для которых выполняется равенство x*x*y=z*z ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача № 2. Сумма нечетных чисел Вычислить сумму всех нечетных чисел из интервала [a, b]. Например, сумма нечетных чисел из интервала [3, 9] равна 3 + 5 + 7 + 9 = 24.
Ответы (1)
Напишите программу нахождения всех натуральных чисел a, b, c из интервала от 1 до 20, для которых выполняется равенство : c = (квадрат суммы) (a2 + b2)
Ответы (1)
Даны три действительных числа: a, b, c. Проверьте, выполняется ли равенство a + b = c. Если равенство выполняется, выведите YES, если не выполняется, выведите NO.
Ответы (1)
Оператор цикла while ... do отличается от цикла for ... to, тем что 1. выполняется хотя бы один раз 2. выполняется хотя бы один раз 3. может не выполняться ни разу 4. выполняется известное число раз 5. выполняется неизвестное число раз
Ответы (1)
Найти все натуральные числа а, b и с из интервала от 1 до 20, для которых выполняется равенство: a^2+b^2=c^2 (составить программу на языке программирования)
Ответы (1)