Задать вопрос
20 октября, 13:08

В Паскале: 1) Найти площадь круга, если известны Пи и Радиус.

2) Найти площадь треугольника если известны h и a

3) Найти площадь трапеции если известны a, b и h

Заранее благодарю

+5
Ответы (1)
  1. 20 октября, 16:18
    0
    1)

    Program CircleS;

    Uses Crt;

    const pi=3.14;

    var S, r:real;

    begin

    Clrscr;

    write ('Введите радиус r:') ;

    readln (r) ;

    S:=pi * (r*r) ;

    writeln ('Площадь круга равна:', S) ;

    end.

    2)

    Program TriangleS;

    Uses Crt;

    var S, a, h:real;

    begin

    Clrscr;

    write ('Введите высоту треугольника h:') ;

    readln (h) ;

    write (' Введите сторону треугольника а:') ;

    readln (a) ;

    S:=0.5*a*h;

    writeln ('Площадь треугольника равна:', S) ;

    end.

    3)

    Program TrapezoidS;

    Uses Crt;

    var S, a, b, h:real;

    begin

    Clrscr;

    write ('Введите высоту трапеции h:') ;

    readln (h) ;

    write (' Введите сторону трапеции а:') ;

    readln (a) ;

    write (' Введите сторону трапеции b:') ;

    readln (b) ;

    S:=0.5 * (a+b) * h;

    writeln ('Площадь трапеции равна:', S) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В Паскале: 1) Найти площадь круга, если известны Пи и Радиус. 2) Найти площадь треугольника если известны h и a 3) Найти площадь трапеции ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
На языке программирования Python напишите программу, которая определяет, какой круг из трех больше, если известно, что R1 - радиус 1-го круга, R2 - радиус 2-го круга, R3 - радиус третьего круга.
Ответы (1)
Дан радиус круга. вычислить площадь и длину окружности этого круга в паскале ABC
Ответы (1)
Пусть элементами круга являются радиус (первый элемент), диаметр (второй элемент) и длина окружности (третий элемент). Составить программу, которая по номеру элемента запрашивала бы его соответствующее значение и вычисляла бы площадь круга.
Ответы (1)
Известны размеры двух ящиков (длина, ширина, высота). Определить объем какого ящика больше. Размеры меньшего ящика увеличить в два раза и снова сравнить объемы ящиков. Вывести на экран больший объем. Составить программу в паскале.
Ответы (1)
Напишите программу. (в Паскале) Дан радиус (R) окружности. Найти длину окружности (С) и площадь круга (S). С=2 ПR. S=ПR^2
Ответы (1)