Задать вопрос
23 сентября, 17:19

Дано несколько чисел. Вычислите их сумму. Сначала вводите количество чисел N, затем вводится ровно N целых чисел.

+5
Ответы (2)
  1. 23 сентября, 17:49
    0
    uses crt;

    var a, n, s:integer;

    begin

    clrscr;

    write ('Введите количество чисел: ') ; read (n) ;

    writeln ('Введите числа:') ;

    for n:=1 to n do

    begin

    read (a) ;

    s:=s+a;

    end;

    write ('Сумма введенных чисел: ', s) ;

    end.
  2. 23 сентября, 20:51
    0
    Смотря для какого тебе языка надо, вот для VisualBasic

    Sub Neskolko_Chisel

    Dim Sum, i, a, N As Integer

    N = InputBox ("Введите количество чисел")

    For i = 1 to N

    a = InputBox ("Введите число")

    Sum = Sum + a

    Next i

    End Sub

    вот для с++

    #include

    #include

    using namespace std;

    int main ()

    {

    setlocale (LC_ALL, "Russian") ;

    int a, N, Sum, i;

    Sum = 0;

    N = 0;

    a = 0;

    cout << "Введите количество чисел! ";

    cin >> N;

    for (i = 1; i < = N; i++)

    {

    cout << "Введите число!";

    cin >> a;

    Sum = Sum + a;

    }

    cout << Sum;

    _getch () ;

    }
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано несколько чисел. Вычислите их сумму. Сначала вводите количество чисел N, затем вводится ровно N целых чисел. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Дано несколько чисел. Напишите программу, вычисляющую их сумму. Сначала вводится количество чисел N, затем вводится ровно N целых чисел. Используйте цикл for.
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Найти: а) сумму всех целых чисел от 100 до 500; б) сумму всех целых чисел от a до 500 (значение a вводится с клавиатуры; a 500) ; в) сумму всех целых чисел от - 10 до b (значение b вводится с клавиатуры; b - 10) ;
Ответы (1)